Galileo Gen. 2 Set Up
- Yavneeka Patel
- Feb 24, 2015
- 3 min read
February 24th, 2015:
Step 1: We will begin by following the documentation provided on the Intel website for Galileo Gen. 2 on a Mac OS X system.
Step 2: Professor St.John set up the SD card using this website for reference:
Download the debian image (galileo-1.2.img.gz (146.2 MB)) from Files.
On the Mac terminal, type the following command to locate the SD Card:
astjohn-mbp:simpleJavaArduino astjohn$ diskutil list
/dev/disk0
You should see the following output on the terminal screen:
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *500.3 GB disk0
1: EFI EFI 209.7 MB disk0s1
2: Apple_HFS Macintosh SSD 499.4 GB disk0s2
3: Apple_Boot Recovery HD 650.0 MB disk0s
Insert the SD Card and run the same command
astjohn-mbp:simpleJavaArduino astjohn$ diskutil list
/dev/disk0
You should see the following output on the terminal screen:
#: TYPE NAME SIZE IDENTIFIER
0: GUID_partition_scheme *500.3 GB disk0
1: EFI EFI 209.7 MB disk0s1
2: Apple_HFS Macintosh SSD 499.4 GB disk0s2
3: Apple_Boot Recovery HD 650.0 MB disk0s3
Run the following command (Note: Disk1 is the SD Card)
/dev/disk1
You should see the following output on the terminal screen:
#: TYPE NAME SIZE IDENTIFIER
0: FDisk_partition_scheme *7.9 GB disk1
1: DOS_FAT_32 53.5 MB disk1s1
2: Linux 1.0 GB disk1s2
To dismount the SD Card safely, run the following command
diskutil unmountDisk /dev/disk1
Step 2: To clone Raspberry Pi SD Cards Using the Command Line use this website for reference.
sudo dd bs=1m if=~/Desktop/galileo-1.2.img of=/dev/rdisk1
This command should take about 4-5 minutes to execute.
Step 3: Connect the Galileo to the Computer
Professor St.John and I had a meeting at 4:00pm that was supposed to last about an hour. In reality, we spent about 2 hours trying to establish a connection.
What Didn't Work: (1)Uploading Ethernet Startup Code from Arduino sketch to Galileo. (2)Connecting through PTTY from terminal
What Did Work: (1)We were able to successfully "ping" the Galileo, meaning the computer recognized the connnection to the Galileo. (2)Connect the USB cable from the Galileo to the Computer. Then, check to see if there is a connection, by typing into the command line ls /dev/cu*ls /dev/cu*. The output should be the connected devices on this stream. Next, connect the Galileo to the Computer through the terminal using the screen command: screen /dev/cu.usbmodem2021 115200. If a successful connection occurs, you should be prompted to enter in the username and password, both of which are "root".
February 25th, 2015:
Attempted to access the Galileo through the terminal again and was unable to succesfully connect. I kept getting told the resource was busy or that it couldn't find a putty. After a few hours of not getting anywhere I gave up. I tried searching the internet for solutions and trying the screen command multiple times. I also attempted to upload the blink arduino sketch, and was unsucessful there, which was good because it showed the galileo was connected to the computer.
March 2nd, 2015:
-Got the Galileo to connect to the Terminal today (multiple times!!!) I don't know why it was different this time around, because I still used the screen command, but somehow it worked.
**Note: on terminal when it looks like nothing is happening, let it be and it should load the login screen** (This may have been part of the problem from last time)
To Expand & Update the File System, I used this site for reference, and followed the steps listed.
PROGRESS accomplished today:
-Expanded file system
-Journal node already created
-Began system update
ISSUES:
-Issue updating system: got a lot of temporary failures. I don't know if this is important, will attach screenshot imminently.
***UPDATE: Talked to Professor St.John, there was an issue connecting to internet. Fixed by allowing Galileo access to internet from the computer network security page and restarting the Galileo.
March 4th,2015:
Continued following the previously listed site to finish the update:
PROGRESS:
-Finished updating system
-Install JDK using the apt-get install oracle-java7 command
-Attempted to run an executable jar file, failed by a lot
March 4th-8th, 2015:
In order to run my code on here, I will need to use the wget command to get the executable jar file from my MHC CS server online.
PROGRESS:
-Made executable jar file of my in-progress code (YAY! Something worked!)
---> In Eclipse, File, Export, Java, Executable Jar File, select destination and name it
-Was unable to get the Galileo to run this file, but I will continue trying!
-I am having a lot of trouble, and am unsure as to why that is...
Recent Posts
See AllSo we've made it to the very end. Through all the ups and downs and we're all still standing. It was an amazing semester and I made some...
/** *Java Speech Grammar Format (JSGF) file *This file holds all the words that the program will recognize **/...
/* * Copyright 2013 Carnegie Mellon University. * Portions Copyright 2004 Sun Microsystems, Inc. * Portions Copyright 2004 Mitsubishi...
Comments